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Adding Ummph to Audio using Pans - Part 2
By Jeff Basch

In the last article we discussed a few tips on how to use
audio panning to give your audio just a bit more edge. In this
article we will expand on the concept based on an experience
taken from a multi-cam shoot.

As you can see from
Figure 1, there are two vid-
eos side by side generated
from the audio and video
tracks shown in Figure 2.
There are multiple ways to
accomplish this. I hap-
pened to use the Video
Wall tool from within Tsu-
nami, but you could also re-
view the March and April
2003 issues of Vegas Tips, Tricks, and Scripts (Vol1 No’s 2
and 3) for more information describing how to create a PIP
effect.

In this case, it is more like a picture beside picture (PBP for
short). This PBP effect was used in older movies for added
effect when two people were talking on the phone and has
become more popular and expanded upon recently in televi-
sion shows like “24.”

One way to give a PBP added impact is by having the
sound of the person on the left side of the screen coming out
of the left speaker with the corresponding sound of the per-
son on the right side of the screen coming out of the right
speaker. One way to accomplish this is to take the audio
associated with each shot and place the audio pan 100% to

the left for one track and 100% right for the other. This is
exactly what was done in Figure 2. Notice how the audio for
track 3 is panned 100% to the left and the audio for track 4
was panned 100% to the right.

However what happens when you are on a multi cam
shoot where this shot is desired and the audio goes bad from
one of the cameras? Never forget Murphy’s law, that if some-
thing can go wrong it will. This is exactly what happened to
me on a shoot a few years back and is what provided the idea
behind this and the previous audio article. As we saw in the
previous issue, you might be able to use the audio from the
one good remaining source and use the track audio envelops
with key markers placed at the key locations on the audio
where you want the audio to be 100% left or right. An ex-
ample of this is shown in figure 3 for the Video in tracks 1 and

Figure 1

Figure 2



World’s first “8x8” dual format writer (8x DVD-R & DVD+R - 4x DVD-RW & DVD+RW)
The DVR-A07 is Pioneer’s first 8x8 dual format writer, meaning it is capable of writing at 8x speed on
DVD-R discs whose standard is being ratified in the DVD Forum and +R discs that are designed for
this recording speed. The new drive also records high-speed DVD-RW and +RW discs at up to 4x
speed, and CD-R and CD-RW discs at up to 24x speed.

* The reliable performance and superior functions of Pioneer’s DVD recording products have earned the respect and trust
of customers

* Pioneers 7th generation DVD burner combines the fastest burn speeds with the highest quality
* The DVRA07 is even easier to use and offers wider compatibility with both -R/RW & +R/RW media

Pioneer DVR-A07 $179.95 ($149.95 after mail-in rebate)
Pioneer DVR-A07 w/ 20 DVD-R 4x disks $199.95 ($169.95 after mail-in rebate)
Pioneer DVR-A07 w/ 50 DVD-R 4x disks $229.95 ($199.95 after mail-in rebate)
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Pioneer DVR-A07 NOW $149.95!!   (After $30 Pioneer mail-in rebate coupon)

2. Another shortcut not men-
tioned in the last article that
can come in handy is to right-
click one of the pan points
and select one of the preset
pan options as shown in fig-
ure 4.

For those of you with
home theatres and Vegas 4 +
DVD, you have many addi-
tional options for panning
sound with the ability to do
Dolby AC-3 surround sound.
Going into the audio tab un-
der file properties and chang-
ing the audio type from ste-
reo to 5.1 Surround changes
the audio track from that
shown in figure 3 to that
shown in figure 5. Notice how
you now have 5 little mini
speakers spread throughout

Figure 3

a box shape. These represent the speaker locations in a typi-
cal surround sound home theatre when looking at the room
from above. Three in the front with the one in the middle
called the center channel, and two in the back.

The other change you will notice is a new key frame sec-
tion added just below the old audio track. The blue diamonds
correspond to all the points that were we previously added
to the old audio track. Selecting any individual key frame will
show you where the sound is going to be located in the
surround sound by a red square. In figure 5, the sound will be
coming out of the front right speaker.

With surround sound, you can set your sound to come
out of any or all of the speakers in various combinations. You
also have access to an added channel called the LFE chan-
nel, which will be the sound going to the sub-woofer. There
are many, many options with sound at this point that are
beyond the scope of this article. However, this should whet
your appetite just a little bit to go explore some of these
options on your own.

Before I close this article, I need to put a word of thanks in
for my children Nicole and Nathan for helping me get the
clips for this article instead of going back to my archives and
pulling something out. I know they did not really want to do
it, but they were troopers anyway.

I hope you enjoyed this article and that it may have
sparked some interest in sound and the role it plays in your
videos. Have fun in your own “Adventures in Sound” and,
as always, I am open to any feedback you may have.

Figure 4 Figure 5

http://www.videoguys.com/images/PDF/033104_DVR-A07_Rebate.pdf
http://videoguys.com/Merchant2/merchant.mv?Screen=BASK&Store_Code=VS&Action=ADPR&Product_Code=DVRA07&Attributes=Yes&Quantity=1
http://videoguys.com/Merchant2/merchant.mv?Screen=BASK&Store_Code=VS&Action=ADPR&Product_Code=A07MEGAKIT&Attributes=Yes&Quantity=1
http://videoguys.com/Merchant2/merchant.mv?Screen=BASK&Store_Code=VS&Action=ADPR&Product_Code=A07MEGA50KIT&Attributes=Yes&Quantity=1
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Creating 3D Text with a Bump Map
www.BorisFX.com

Both Graffiti and Red allow you to apply reflection maps,
bump maps and texture maps to 3D objects. In this exercise,
you will animate text using the onscreen OpenGL interactors.
Three sets of onscreen interactors allow you to position,
scale and rotate tracks. After you animate the text, you will
apply a bump map. You can complete this exercise in Boris
Red 3GL or Boris Graffiti 3.0.
1. Launch the Red Engine or the Graffiti KeyFramer.
2. Create a new composition or setting:

* If you are using Boris Red, choose File > New Project.
* If you are using Boris Graffiti, choose File > New Set-

tings.
3. Set the duration of the ef-

fect to two seconds by typ-
ing 200 into the Duration
field in the Timeline window and pressing Enter.

You can only use the Duration field when you work
in the KeyFramer or Red Engine. When you use
Boris in a host application, you set the duration in

the host application so typing in this field has no affect. To
complete this tutorial using the plug-in, apply Boris Red or
Graffiti to a two-second clip in your timeline then follow the
tutorial beginning at Step Five.
4. Press the Media icon on the bottom track and choose
Movie File . Import the movie file “Water.mov.”

If you didn’t download the Water.mov file, simply
press the Media icon on the bottom track and
choose Color to create the text over a colored back-

ground.

5. Double-click the top track (Graffiti) or press the Media
icon on the top track and choose Text for the source media
(Red). The Text window appears.
6. Click in the Text window and type “Boris.”

www.borisfx.com

For more information,
call 888-77BORIS

The illustrations use the word “Boris” with 132 point Den-
mark font but you can create whatever you want.
7. Select the text that you typed. Make sure that you have
not added a shadow or a border to the text.
8. Click Update and close the Text window. The track is auto-
matically renamed “Boris.”

You don’t need to format the text, since you will convert it
to a 3D Extrusion. But first you will animate your logo. Set-
ting up the animation using Text media applied to a 3D Plane
shape accelerates your previews.
9. Press the Quality button in the Composite win-
dow and choose Draft . This will allow you to work
more quickly.
10. You should see red, green and blue OpenGL interactors in
your Composite window. If
you don’t, press the G key or
choose Preview > OpenGL
Interactors > Show Interactors.

In the onscreen interactor
controls, red represents the X-
axis, green represents the Y-
axis and blue represents the Z-
axis. When you click an
interactor’s axis, movement,
scaling and rotation are con-
strained to that axis. Clicking
the image but not an interactor
allows freeform positioning,
scaling and rotation.
11. Press the E key or choose Preview > OpenGL Interactors
> Rotate Interactor. The interactors should display spheres
at their ends to indicate that you are in Rotate mode.
12. With the first keyframe in the text track selected, drag the
red interactor in the Composite window until the Tumble X
value is approximately -45 degrees .

http://www.borisfx.com
http://www.borisfx.com
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The Tumble X, Spin Y and Rotate Z values update in the
Controls window as you drag.
13. Press the W key or choose Preview > OpenGL Interactors
> Translation Interactor. The interactors should display ar-
rows at their ends to indicate that you are in Translation
mode.
14. With the first keyframe in the text track still selected, drag
the green interactor up in the Composite window until the
text is not longer visible onscreen. The Position values up-
date in the Controls window as you drag.
15. Click the Play button to preview the effect.

Time 00:00:00:20 Time 00:00:01:10 Time 00:00:02:00

Extruding the Text
Now that the motion is finished, you will extrude the text.
1. Press the Boris track’s Shape icon and choose 3D Extru-
sion from the menu.

By default, a plastic material is assigned to all four sides
of the text.
2. Select the
first keyframe
in the Boris
track but move
the CTI into the effect so that you can see the text.
3. Click the Animate button in the bottom of the
Controls window. This button toggles between Con-
stant and the default interpolation. Constant interpolation
makes parameters static and does not create
keyframes. The top button shows the Animate but-
ton in the Default interpolation; the lower button shows the
Animate button in Constant interpolation. You want Con-
stant interpolation.
4. Click the Extrusion tab in the Controls window. Set Extru-
sion to 6 with Constant interpolation.
5. Click the Materials tab in the Controls window. Set the
Face Count menu to 1 and choose Gold from the Type menu.

Setting the Face Count to 1 applies the same material to all
faces of the text. When you choose Gold, the Gold material
parameters appear in the tab.
6. In the Materials tab, set Reflectivity to 80 with Constant
interpolation and set Shininess to 40 with Constant interpo-
lation.
7. Play the sequence by clicking the Play button in the Com-
posite window or by pressing the Space bar.

Creating a Bump Map
Now you will add a bump map to your text. You can create the
bump map from a procedural texture or you can use a media
file. You will use a procedural texture.
1. Press the Quality button in the Composite win-
dow and choose High . This will allow you to view
the bump map.
2. Select the first keyframe in the Boris track but move the
CTI into the effect so that you can see the text. Click the
Bump Map tab in the Controls window.
3. Select the checkbox for the Front Face.
4. Make sure that the Source menu is set to Procedural.
This is the default setting.
5. Choose Reptilian from the Type menu. Reptilian creates
a texture resembling a
scaly or spotted ani-
mal skin.
6. In this instance,
the animal skin makes
the text difficult to
read. So deselect the
Color On checkbox.
When this checkbox is
deselected, the color values of the underlying material also
set the color values of the applied bump map; the bump map
only sets the luminance values.
7. Move the CTI to the beginning of the timeline and choose
Preview > Preview to RAM. Now the text uses the Reptilian
bump map with the gold material.

Time 00:00:00:20 Time 00:00:01:10 Time 00:00:02:00
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Beginner’s Corner - Text Compositing
By Edward Troxel

The last two issues have discussed various text
options and moving text. Continuing to build on this topic,
we’ll continue with more complicated compositing op-
tions.

We’ve all seen the introductions to shows such as
Baywatch or Spin City where the text of the show name
is filled with video - often overlaid over another differ-
ent video feed. This effect is very easy to achieve in
Vegas.

To achieve this effect, start with a new project con-

taining two video tracks. On track one, add a standard
text generated media and on track two place the video
to be used inside
the letters. After
this has been done,
you should see the
image overlaid over
the video as shown
in this sample
screen.

The next step is to modify the Parent/Child rela-
tionship between these two tracks. On the far left side

of track two is an arrow
pointing upwards. This ar-
row controls the Parent/
Child relationship. Click on
the arrow to the left of
track two and it will change
to a line joining with the ar-

row on track one as shown in these before and after
images.

After setting the Parent/Child relationship, the video
will immediately change from showing around and be-

hind the text to be-
ing shown inside
the text. This
screen shot shows
the background
video showing in-
side the text

Now that the
hard part has been achieved, it is time to add the back-
ground video layer. Add a third track to the Vegas

timeline and place the background video on that track.
The video place on the third track will now appear in
the area around the letters filled with video. The final
result can be
seen in this
s a m p l e
screenshot.

O n c e
these steps
have been
completed, the
result will be
letters filled
with moving video over a moving video background.
Experiment using different techniques such as moving
text (described in the last issue) filled with moving text
over moving video.

Using a little imagination, the text options in Vegas
provide a wide variety of options and can fill most titling
needs. Expand on these principles and Vegas’ titling
abilities can help spruce up your videos.



     Excalibur Add-on - Remove Non-Comment Markers

/**
 * This add-on will remove all non-comment markers so comments may be
 * added when using the Multi-Cam Wizard and only the comments will remain
 * upon completion. The ">" will also be removed from the comment names.
 * This will facilitate adding DVD chapter points during the editing process.
 **/
import SonicFoundry.Vegas;

try {
  var regMarkers = Vegas.Project.Markers;
  var i;

  for (i=Vegas.Project.Markers.Count - 1; i >= 0; i--) {
    var currMark = regMarkers[i].Label.substr(0,1);

    if (currMark == ">") {
      regMarkers[i].Label = regMarkers[i].Label.substr(1,999)
    } else {
      Vegas.Project.Markers.Remove(regMarkers[i]);
    }
  }

} catch (e) {
}
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Expanding Excalibur - Selectively Delete Markers
By: Edward Troxel

 The latest version of the Multi-Cam Wizard in Excalibur
allows comments to be added that are ignored when running
the Multi-Cam Wizard. This allows you to add notes without
affect the normal operation of the program. An enterprising
user of Excalibur came up with an idea for another use: Pre-
setting marker points for use in DVD Architect.

There was a problem with this theory: the options were to
delete ALL markers or manually delete all non-comment mark-
ers. This would be a very time-consuming process. Beyond
that, all of the comment markers begin with “>” which really
need to be removed before transferring them to DVD Archi-
tect.

What was needed was an option to selectively delete all
non-comment markers and automatically remove the com-
ment indicator - “>” - from the beginning of each of the com-
ments.

The first step is to go through the list of markers, starting
with the last one, and look at each one going backwards. You
need to start at the end and go backwards because deleting
markers confuses things when going forward. So, we begin
with a for loop, beginning at the end, and proceeding to the
beginning.

Contact Information
Send your tips, tricks, article ideas, script ideas,
questions, articles, or registration requests to:

vegastips@jetdv.com

To register on the web to receive this newsletter,
browse to:  www.jetdv.com/tts

Thank you,  Edward Troxel

for (i=Vegas.Project.Markers.Count - 1; i >= 0; i--)

Next you have to look at the label of each marker and
determine whether it is a comment. If the marker is a comment,
change the marker name eliminating the “>” from the begin-
ning of the label name. However, if the label is not a marker,
you then delete that marker.

After running the script below, all markers that are not
comments will be removed and all comments will be con-
verted into non-comments. This will allow for the pre-naming
of marker points for DVD Architect.


